Manual PayPal Payments
Incident Report for Global Services
Postmortem

We've re-enabled PayPal today. You can now order with PayPal using our site, and everything is automated.

Once again, thanks for choosing Spotify Global.

Posted Mar 27, 2021 - 00:25 UTC

Resolved
This incident has been resolved.
Posted Jan 01, 2021 - 00:22 UTC