Automated Fulfilling Issues
Incident Report for Global Services
Monitoring
The Sellix has been updated but the site has not. For the time being, please use https://sellix.io/globalservices
Thanks
Posted Mar 27, 2021 - 10:06 UTC
Update
We are continuing to work on a fix for this issue, please bear with us. Meanwhile, please open a ticket if you would like to make a purchase.
Posted Mar 27, 2021 - 00:40 UTC
Identified
Our current site hasn't been updated to our newest Sellix. We'll try to fix this as soon as possible.
Posted Mar 27, 2021 - 00:33 UTC
This incident affects: Spotify (Spotify Site, Spotify Bot) and Payment Methods (PayPal, Bitcoin (BTC), Other Crypto).